Is my MegaDrum broken?

Discussions of any related software

Moderator: Related software moderators

Re: Is my MegaDrum broken?

Postby ibanman555 » Wed Jan 27, 2021 3:10 pm

We may need to hear back from Dmitri regarding the possible hardware issue. As far as updating is concerned, where is the firmware file located on your PC? IN command prompt, you need to place the file in the directory CMD is looking, or ~cd (change directory) to point to the directory the file is located. When updating using MDM, did you boot up MD with left button pushed or no?
ibanman555
 
Posts: 276
Joined: Sat Jan 28, 2012 8:44 pm
Location: Upstate New York (Adirondacks)

Re: Is my MegaDrum broken?

Postby dmitri » Wed Jan 27, 2021 3:35 pm

The snare settings in MDMFX don't look like default settings. Please do the following:
1. Power up MegaDrum while the RIGHT button is pressed to force default settings.
2. Load the whole config from MegaDrum into MDMFX
3. Take a screenshot of Snare settings with MIDI Log showing the output while it is firing.

To update firmware from MDMFX:
1. Power up MegaDrum normally.
2. Connect MDMFX to MegaDrum (it should show FW Version and MCU correctly)
3. Go to Main->Firmware Upgrade and follow the instructions it shows there.
dmitri
Site Admin
 
Posts: 8537
Joined: Fri Aug 03, 2007 8:05 pm

Re: Is my MegaDrum broken?

Postby jclark1118 » Wed Jan 27, 2021 4:20 pm

Powered on MD with the right button pressed in and it had no change.

Successfully flashed firmware and still no change

Below is a screen shot with the snare midi still going

Screenshot 2020-12-29 211057.png
You do not have the required permissions to view the files attached to this post.
jclark1118
 
Posts: 36
Joined: Sun Dec 20, 2020 7:15 pm

Re: Is my MegaDrum broken?

Postby dmitri » Wed Jan 27, 2021 4:31 pm

Then it is a hardware issue. Let's continue over email about a replacement.
dmitri
Site Admin
 
Posts: 8537
Joined: Fri Aug 03, 2007 8:05 pm

Re: Is my MegaDrum broken?

Postby sully » Tue Feb 01, 2022 4:43 pm

Hi Dmitri,

I bought a 56 input MegaDrum from you in 2020 and everything was working as expected up until last month.

I turned it on one day and it started triggering continuously - as described in this thread.

The triggering is happening on inputs 23/24 so I've had to deactivate these completely. Also, a number of the other inputs have stopped working altogether (1, 29, 30,and 32) and I've had to move the triggers into alternative inputs for now.

I've tried pretty much everything you've suggested here and nothing seems to fix the issue.

I'm currently running firmware version 20200331

Is there anything you can do to help please?

Many thanks,

Andy
sully
 
Posts: 1
Joined: Sun Mar 21, 2021 8:50 pm

Re: Is my MegaDrum broken?

Postby dmitri » Tue Feb 01, 2022 6:58 pm

If it is a hardware issue, please PM me or send an email and we'll arrange a repair.
dmitri
Site Admin
 
Posts: 8537
Joined: Fri Aug 03, 2007 8:05 pm

Re: Is my MegaDrum broken?

Postby kutluhan34 » Sat Sep 10, 2022 11:27 pm

hi everyone..were you able to solve this problem? how? i am having the same problem. same as described... i would appreciate if you could help me. I used 56input versiyon,mega644-20pu,non protected firmware.I couldn't find any problem in pcb. I rewrote mega644 myself with nonprotected bootloader firmwire. I updated it (..2010..) to the bootloader I have with midiox. same problem repeats. Also, no jack is plugged into the megadrummother board. I even removed the 74hc4851 Ic..the same situation continues. Now that I can rewrite the bootloader.hex atmega644 myself, can I say my atmega is intact? Could this problem be related to pic18f2550?
kutluhan34
 
Posts: 3
Joined: Fri Apr 21, 2017 11:37 pm

Re: Is my MegaDrum broken?

Postby dmitri » Sun Sep 11, 2022 6:33 pm

If you problem is EXACTLY the same then one of you MUXers (74hc4851 ) is broken. If it is not EXACTLY the same then it can be anything - you will have to track with a multimeter/oscilloscope where the problem is.
dmitri
Site Admin
 
Posts: 8537
Joined: Fri Aug 03, 2007 8:05 pm

Re: Is my MegaDrum broken?

Postby kutluhan34 » Mon Sep 12, 2022 2:27 am

dmitri wrote:If you problem is EXACTLY the same then one of you MUXers (74hc4851 ) is broken. If it is not EXACTLY the same then it can be anything - you will have to track with a multimeter/oscilloscope where the problem is.


Thank you very much, Dimitri. you Wake me up. Removing all MUXers (74hc4851) Ics fixed the problem.
Earlier; I just removed the muxer of the pin that was constantly triggered.(my board on; the aux1-H triggered constantly and I only removed the mxu IC connected to it. It was constantly triggering..).
but when dimitri said, then i also disassembled the 7 muxer. continuous triggering is over. i tried each one. I detected the corrupt muxer.
Although the muxer connected to the incorrectly triggered channel is intact, another muxer is broken, which can cause this situation.
kutluhan34
 
Posts: 3
Joined: Fri Apr 21, 2017 11:37 pm

Previous

Return to Related Software

Who is online

Users browsing this forum: No registered users and 19 guests

cron